Scheduled for Nov 4 2023 at 7:45 PM – 8:45 PM
Completed
Nov 4 2023 at 8:45 PMCompleted
Nov 4 2023 at 8:45 PMMaintenance has completed successfully
In progress
Nov 4 2023 at 7:45 PMIn progress
Nov 4 2023 at 7:45 PMMaintenance is now in progress
Planned
Nov 4 2023 at 7:45 PMPlanned
Nov 4 2023 at 7:45 PMHello, everyone. Due to issues with our current Virtual Private Server provider, we are going to be moving to Digital Ocean. This can take a while, and all of our services will be down in the meantime.
In progress
Nov 4 2023 at 7:44 PMIn progress
Nov 4 2023 at 7:44 PMMaintenance is now in progress.